Get Adobe Flash player

Ćwiczenia Logo Komieniusz

Procedury pierwotne w programie LOGO Komeniusz dzieli się na polecenia (instrukcje) i funkcje (procedury, które mają wartość)

Opis wszystkich procedur pierwotnych znajdziesz w Pomocy programu Logo Komeniusz.

Dodatkowo, na płycie CD-ROM, w bloku tematycznym ALGORYTMY | PROCEDURY JĘZYKA LOGO,

przygotowane są opisy procedur, których użyjesz podczas wykonywania ćwiczeń.

 

 

Po uruchomieniu programu LOGO Komeniusz i poznaniu żółwia, który potrafi wykonywać Twoje polecenia.

Musisz pamiętać ,że żółw zrozumie wydawane przez Ciebie polecenia pod warunkiem, że napiszesz je w języku dla niego zrozumiałym,

a więc w jezyku Logo. Poznasz najpierw te polecenia, które żółw już zna, czyli procedury pierwotne.

Żółw wykonuje twoje polecenia, wędrując po wydzielonej części ekranu, zwanej ekranem graficznym. Poniżej umieszczony jest ekran tekstowy,

w którego obszarze znajduje się wiersz poleceń. W wierszu tym będziesz wypisywać wszystkie polecenia żółwia.Pojawią się w nim także różne komunikaty,

które będzie miał Ci do przekazania żółw.

 

PIERWSZE SPOTKANIE Z ŻÓŁWIEM

Jeśli chcesz zobaczyć żółwia musisz wpisać polecenie (oznacza ono ,,pokaż żółwia") i nacisnąć klawisz ENTER. Na ekranie pojawi się

wówczas domyślna postać żółwia w kształcie małego trójkąta skierowanego do góry (rys. 130). W dalszej części dowiesz się jak można zmienić jego postać

na np. taką, która będzie rzeczywiście przypominała żółwia.

Żółw zniknie z ekranu po wydaniu przez Ciebie polecenia (,,schowaj żółwia").


Przedstawię teraz kilka najważniejszych poleceń które pozwolą Ci sterować żółwiem. naprzód ( w skrócie np), wstecz (ws), W tym przypadku nie wystarczy samo wpisanie samej nazwy polecenia

musisz bowiem wpisać także parametr, który określi, jaką odległość ma pokonać żółw. Jeśli chcesz obrócić żółwia musisz napisać także inne polecenia prawo (pw) lub lewo (lw), wraz z parametrem

określającym kąt obrotu. Pamiętaj o tym że żółw wykona Twoje polecenie wtedy gdy zatwierdzisz wciskając ENTER.


Ćwiczenie 1

Obracaj żółwia w prawo, potem w lewo, starając się za każdym razem przewidzieć, jak będzie skierowany. Następnie schowaj żółwia

i każ mu się obrócić. Zgadnij jak skierowany jest żółw, a potem każ mu się pokazać, aby sprawdzić, czy Twoje przewidywania były słuszne.


Aby żółw obrócił się o 40  stopni w prawo, napisz pw 40. Zwróć uwagę aby oddzielić nazwę polecenia od parametru spacją. Jeśli o tym zapomnisz i napiszesz pw40, żółw nie zrozumie Twojego polecenia

i skieruje do Ciebie komunikat o następującej treści : Błąd : Nie wiem jak wykonać pw40. Możesz taką pomyłkę poprawić wpisując w nowym wierszu poprawną treść polecenia.


Ćwiczenie 2

Przesuwaj żółwia po ekranie graficznym i obracaj go w taki sposób, aby żółw obrysował kontury ekranu,

tzn. powędrował jak najbliżej jego krawędzi i zakreślił jak największą ramkę.


UWAGA ! DO WYKONYWANIA ĆWICZEŃ BĘDĄ CI POTRZEBNE RÓŻNE KOMENDY KTÓRE ZNAJDZIESZ W ARTYKULE Komendy Logo Komeniusza


Ćwiczenie 3

Wykonaj żółwiem rysunek podobny do poniższego.


 

ŻÓŁW RYSUJE FIGURY GEOMETRYCZNE

Wykorzystując odpowiednie polecenia sterując ruchem żółwia możesz mu zlecić narysowanie różnych figur geometrycznych.


Ćwiczenie 4

Narysuj trójkąt równoboczny o boku długości 100 kroków.

w rozwiązaniu zadania będzie ci pomocny rys. 132, z którego wyczytasz jakie obroty musi wykonać żółw.



Zapewne zorientowałeś się na podstawie tego rysunku że żółw musi wykonać następujący ciąg poleceń :

np 100

lw 120

np 100

lw 120

np 100

lw 120

Pamiętaj o tym aby po każdym poleceniu zatwierdzać przyciskiem ENTER oraz pamiętać o dawaniu spacji między poleceniem a parametrem

Możesz także te wszystkie polecenia napisać w jednym wierszu: np 100 lw 120 np 100 lw 120 np 100 lw 120

wówczas klawisz ENTER naciskasz na końcu.


Ćwiczenie 5

Narysuj kilka trójkątów równobocznych, każdy o innej długości boku. Nie łącz trójkątów liniami,

lecz tam gdzie jest to konieczne, przesuwaj żółwia z podniesionym pisakiem.


Ćwiczenie 6

Przeanalizuj wynik wykonania przez żółwia poniższych poleceń:

cs np 40

ścier ws 20

Zauważyłeś że żółw najpierw narysował linię długości 40 kroków, a następnie zgodnie z podanymi instrukcjami oraz parametrem

wymazał je do połowy .

Dodam jeszcze że polecenie ws możesz zastąpić poleceniem np z ujemną liczbą kroków i odwrotnie. Podobnie jest z poleceniem

pw i lw - obrót w prawo o daną liczbę stopni możesz zastąpić obrotem w lewo o liczbę stopni przeciwną do danej.


Ćwiczenie 7

Sprawdź słuszność powyższych uwag, analizując wykonanie następujących poleceń:

cs

np 100 pw 144 czekaj 1000 np 70 czekaj 1000 ścier np -70 pw -144 czekaj 1000 np -100

 

GRUPOWANIE CZYNNOŚCI POWTARZALNYCH

Ćwiczenie 8

Spraw aby żółw narysował kwadrat, którego długość boku wynosi 60 kroków.


Aby nie pisać po 4 razy jednego polecenia, możesz posłużyć się komendzie która powtarza wielokrotnie daną grupę poleceń.

Jest to możliwe dzięki zastosowaniu polecenia powtórz, do którego wykonania żółw potrzebuje dwóch danych: musi wiedzieć, jaką grupę poleceń oraz

ile razy ma powtórzyć. NP. powtórz 4 [np 60 pw 90]


Ćwiczenie 9

Tym razem instrukcję powtórz wykorzystaj do narysowania trójkąta równobocznego i sześciokąta foremnego. Długość boku wybierz sam.


Ćwiczenie 10

Sprawdź, co narysuje żółw, jeśli wydasz mu polecenie:

powtórz 5 [np 120 lw 144]


Ćwiczenie 11

Wykonaj kilka nowych rysunków, zmieniając postać instrukcji z poprzedniego ćwiczenia. Podawaj różne liczby powtórzeń,

długość boków i wartości kąta. Nie wpisuj każdego polecenia od nowa. Wyświetl sformułowane wcześniej polecenia korzystając z klawisza ze

strzałką skierowaną do góry lub w dół, a następnie zmodyfikuj je.


Ćwiczenie 12

Narysuj okrąg.

Podczas rysowania wielokątów foremnych zauważyłeś z pewnością że zwiększając liczbę boków wielokąta, otrzymujesz figurę zbliżoną do okręgu.

Sformułuj polecenie : powtórz 36 [np 20 lw 10]

Przekonaj się że zwiększając liczbę boków wielokąta nie otrzymasz dokładniejszego rysunku okręgu. Zatem możesz przyjąć, że aby żółw narysował okrąg,

należy zlecić mu narysowanie wielokąta foremnego o 36 bokach.


Ćwiczenie 13

Narysuj półokrąg.

 

WYKONYWANIE OBLICZEŃ

Pokażę Ci teraz, w jaki sposób można wykonywać w Logo proste obliczenia.

Wykorzystasz do tego celu między innymi, polecenia pisz (ps) oraz wpisz


Ćwiczenie 14

Co pojawi się na ekranie tekstowym, gdy wydasz poniższe polecenia?

pisz 123

pisz "Ala

pisz 6 * 3 * 17

pisz [Dziś jest zimno]


Ćwiczenie 15

Przekonaj się, jaki będzie wynik następującego polecenia :

(pisz [360 : 5 =] 360 / 5)


Do wykonania następnego ćwiczenia wykorzystasz polecenie wpisz


Ćwiczenie 16

Sprawdź wyniki poniższych poleceń :

wpisz [12 * 5 =]

wpisz 12 * 5


Ćwiczenie 17

Oblicz ile wynosi √360 * 2 + 100


Aby obliczyć pierwiastek kwadratowy musisz skorzystać z funkcji pwk.

 

DEFINIOWANIE I WYKONYWANIE WŁASNYCH PROCEDUR

Poznałeś już wiele procedur, które żółw potrafi wykonać. W poprzednich ćwiczeniach wykonywałeś różne figury geometryczne gdzie musiałeś wpisywać np. powtórz 4 [np 60 pw 90]

żółw narysował kwadrat, o boku długości 60 kroków.  Czy mógł byś sprawić aby po napisaniu słowa kwadrat, narysuje się on. Otóż tak!

Żółw Logo jest "inteligentny" więc możesz go nauczyć jak ma wykonać twoje polecenie.


W pierwszym wierszu ekranu tekstowego wpisz oto kwadrat i naciśnij klawisz ENTER. Na razie utworzyłeś jedynie nagłówek procedury. Teraz musisz wpisać treść procedury, w której pokażesz

żółwiowi informacje na temat tego jakie czynności powinien wykonać w celu narysowania kwadratu. Napisz więc powtórz 4 [np 60 pw 90] i znów naciśnij klawisz ENTER. Aby poinformować żółwia

że zakończyłeś definicję procedury w nowym wierszu wpisz już.


Zdefiniowane procedury możesz obejrzeć w oknie pamięci. Jest ona dla żółwia czymś w rodzaju notatnika. Okno pamięci możesz otworzyć

wybierając z menu OKNO polecenie POKAŻ PAMIĘĆ lub korzystając z klawisza F4 (rys. 133)



Procedury można łatwiej definiować w przeznaczonym do tego celu edytorze procedur. W kolejnym ćwiczeniu przekonasz się jak się korzysta z edytora procedur.


Ćwiczenie 18

Zdefiniuj procedury rysowania trójkąta równobocznego i pięciokąta foremnego. Długość boku wybierz samodzielnie


Najpierw otwórz okno pamięci, a następnie OBIEKTY polecenie DODAJ PROCEDURĘ. Otworzy się wówczas okno widoczne na rys. 134 .

Wpisz nazwę procedury trójkąt i kliknij na przycisku OK. W oknie edytora pokazał Ci się gotowy schemat opisu procedury rys. 135.

 

DEFINIUJESZ PROCEDURY Z PARAMETRAMI

Ćwiczenie 19

Zdefiniuj procedurę kwadraty, tak aby w wyniku jej powstał na ekranie rysunek, który przedstawiam Ci obok.


Ćwiczenie 20

Zdefiniuj procedurę figura, służącej do narysowania wielokąta foremnego o dowolnej liczbie boków i długości boków.

Do narysowania wielokąta foremnego potrzebna Ci jest liczba boków i długość boku.

nazwy parametrów dobierz tak, aby sugerowały co prezentują :ile - to liczba boków :bok - to długość boku

Wzorem procedury rysowania wielokąta  może być dla Ciebie procedura rysowania kwadratu. Jakie czynności tym razem wykona żółw ?

Otóż będzie rysował jeden bok i obracał się o kąt 360 / :ile

oto figura :ile :bok

powtórz :ile [np :bok pw: 360 / :ile]

już

Poniżej przedstawiam CI przykłady, które ilustrują,

w jaki sposób przypisuje się zmiennym wartości. Napisz w wierszu poleceń :

przypisz "liczba 123

przypisz "zdanie [Czas na Logo]

przypisz "x :liczba + 77

Pierwsze polecenie utworzyło zmienną o nazwie liczba i przypisało tej zmiennej wartość 123,

drugie - zmienną zdanie, przypisując jej listę [Czas na Logo], trzecie - zmienną x, przypisując jej wartość zmiennej liczba powiększoną o 77.

W pierwszym poleceniu "liczba oznacza nazwę zmiennej, natomiast w trzecim poleceniu :liczba oznacza wartość zmiennej o nazwie liczba.

Aby odczytać wartość utworzonych zmiennych, napisz:

pisz :liczba

pisz :zdanie

pisz :x

Ćwiczenie 21

Zmodyfikuj procedurę figura w taki sposób, żeby kąt obrotu żółwia nie był obliczany przy każdym powtórzeniu.

Utwórz zmienną o nazwie obrót i nadaj jej wartość kąta obrotu żółwia. Oto nowa postać procedury:

oto figura :ile :bok

przypisz "obrót 360 / :ile

przypisz "bok :obwód / :ile

powtórz :ile [np :bok pw :obrót]

już

Wywołaj przedstawione poniżej procedury, by sprawdzić, jak żółw rysuje różne wielokąty o obwodzie długości 800 kroków.

figury 4 800

figury 12 800

figury 30 800

Ćwiczenie 22

Zdefiniuj procedurę rysowania okręgu o promieniu dowolnej długości.

Procedura rysowania okręgu będzie miała ostatecznie następującą postać:

oto okrąg :promień

powtórz 36 [np 0,175 * :promień pw 10]

już

Ćwiczenie 23

Otwórz plik OKRĘGI i przeanalizuj w oknie pamięci treść zawartych w nim procedur.

Zastanów się, jaki rysunek powstanie w wyniku wywołania procedury pawie_oczko. Sprawdź, czy odgadłeś efekt jej działania.

Zauważ że procedura rysowania okręgu jest wykonywana wielokrotnie, za każdym razem z parametrem o innej wartości.

Wartość parametru promień jest zmieniana w wyniku wykonania instrukcji przypisz "promień :promień + 20,

którą można opisać w taki sposób: do wartości zmiennej promień dodaj 20 i nadaj tej zmiennej nowo obliczoną wartość.

Ćwiczenie 24

Napisz procedurę rysowania spirali zwijającej się do środka, przedstawionej na rysunku obok .

Na podstawie analizy rysunku można wywnioskować, że każdy bok spirali jest mniejszy od poprzedniej i tworzy z nim kąt 90°

Jeśli założysz, że najdłuższy bok ma długość 150 kroków,

a każdy z boków jest mniejszy od poprzedniego o 2 kroki żółwia, procedura będzie mieć następującą postać:

oto spirala

przypisz "bok 150

powtórz 75 [np :bok pw 90 przypisz "bok :bok - 2]

już




Poprawiony (środa, 16 listopada 2011 09:28)